Tuesday, February 13, 2018

The Things I Do For Love (or, How Not to Spend Your Day)

grumble . . .

Ten years ago this spring, I ordered a monster Mac Pro:
  • Eight 3.2 Ghz processor cores, 
  • 8G of memory, 
  • Dual video cards (to drive up to 4 30" monitors)
  • 30" HP Monitor
  • Two 500 GB drives
  • Two Ethernet ports
  • WiFi
  • Bluetooth
The PC tower-sized case was all aluminum, and the beast weighed ~ 42 pounds. The primary internal upgrades to it over the years has been two SSD drives (160GB and 500GB) and a USB 3 card. Thus configured, it can compete with far more recent machines; it is worthy of its name "xena, the Warrior system".

It can even boot Windows 10 Pro 64-bit (the 160GB SSD was dedicated to that.)

Last spring, I switched to a new iMac for non-performance related reasons:
  • Parity with Katherine's Mac (replaced at the same time),
  • Lower power consumption, 
  • Support for newer MacOS operating systems. 
xena retired to the library, where I would wake it up every few weeks or months to update its software. When it has been awake, I have slowly purged various software and data off it (we *really* don't need a third copy of the ~8900 track music library or extra copies of various disk hogging virtual machines). The reduced space requirement meant I could move Windows 10 over to the 500GB SSD and use the 160GB SSD elsewhere, such as on one our proliferating Raspberry Pi systems.

Alas, I forgot I would be dealing with Microsoft licensing.

I had played Mr. Potato Head with xena when it moved and replaced the monitor, USB hubs, keyboard, & mouse, and pulled the 160 GB SSD drive. Internally, it was still the original internal configuration except for the missing SSD. But when I reinstalled Windows 10 on a second partition of the 500GB drive, Windows announced it could not be customized until it was activated, and it could not be activated because it wasn't the same system. It suggested that "please visit the Microsoft Store ...".

I
didn't think Theseus's paradox applied, but I'm not Microsoft.

So I plugged in most of the external peripherals I had on xena when it in was my office, reinstalled the SSD drive, and rebooted. Windows Pro 10 then said that it was installed on top of a previous version that had never been activated, and "please visit the Microsoft Store ...".

The primary factors that kept the xena from being thrown out the nearest window were a) that window does not open and b) the xena is not a petite machine.

I did the smart thing and went out to dinner.

Then I reinstalled again. First I put on Windows 7 64-bit, then activated it, and then upgraded to Windows 10 Pro. I then signed into my Hotmail (Microsoft account).

Voila!
I'm not quite what I did different, but Windows 10 Pro is happily fully functional. Now if I only knew what secret sauce I applied this time ...

. . . grumble 

No comments:

Post a Comment